Fin Dashboards Failing to Load
Incident Report for Fin
Resolved
We're back, this has been resolved and dashboards are loading normally
Posted Apr 27, 2022 - 17:50 UTC
Identified
Since 9:20am PST Fin dashboards are failing to load, this is due to an outage on the AWS service that we use to serve queries. We will continue to update as we have more details or as the outage resolves.
Posted Apr 27, 2022 - 16:20 UTC
This incident affected: Analytics Data.