Data Processing Delayed
Incident Report for Fin
Resolved
We are all caught back up, dashboards are updating regularly.
Posted Mar 04, 2022 - 00:05 UTC
Identified
Data processing is delayed for Fin's dashboards. Our team is working to remedy this issue and catch back up to realtime. No data loss will occur, we will update once we are caught back up.
Posted Mar 03, 2022 - 21:27 UTC
This incident affected: Analytics Data.